Cloud Server Backup Service
Cloud Server Backup Service
- What's New
- Service Overview
- Getting Started
- User Guide
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Best Practices
- Using a Custom Script to Implement Consistent Backup for MySQL
- Using a Custom Script to Implement Consistent Backup for SAP HANA
- Using a Custom Script to Implement Consistent Backup for Other Linux Applications
- Troubleshooting a Custom Script Error
- Verifying the Application-Consistent Backup Result (Linux)
- Verifying the Application-Consistent Backup Result (Windows)
- Protecting SQL Server in Failover Cluster Mode
- Protecting SQL Server in Always on Availability Groups Mode
- Change History
- API Reference
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FAQs
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About Concepts
- What Is CSBS?
- What Are Full Backup and Incremental Backup?
- What Is Consistent Backup?
- What Are the Differences Between CSBS and VBS?
- What Is a Backup Policy?
- What Are the Differences Between Backup and Disaster Recovery?
- What Are the Differences Between Backup and Snapshot?
- Why Is the Disk Space Usage Displayed in the File System Different from the Backup Size?
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About Pricing
- How Is CSBS Billed?
- How Do Yearly/Monthly Resource Packages Function When I Have Bought More Than One?
- Are CSBS and VBS Resource Packages Interoperable Between CSBS and VBS?
- Why Am I Charged in Pay-per-use Mode Although I Have Purchased Resource Package?
- What Exactly Are the Function Package and the Storage Package?
- Will the CSBS Backups Displayed on the VBS Page Be Charged Repeatedly?
- How Do I Query CSBS Pay-Per-Use Billing Details?
- Why Is the Fee Deducted After a Backup Is Deleted?
- How Do I Disable CSBS?
- How Do I Stop CSBS from Charging?
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About Backup
- Does CSBS Support Backing Up All EVS Disks on an ECS?
- Do I Need to Stop the ECS Before Backing It Up?
- Can an ECS with Application Systems Be Backed Up?
- What Are the Minimum Backup Frequency and Maximum Number of Retained Backups Supported by CSBS?
- How Can I Distinguish Automatic Backups From Manual Backups?
- How Can I Configure a Backup Policy?
- Can I Choose to Back Up Only Some Partitions of a Disk?
- Does CSBS Support Cross-Region Backup for ECSs?
- Which Types of Databases Can Be Backed Up Using Database Server Backup?
- How Do I Select Among Database Server Backup, Cloud Server Backup, and Disk Backup?
- How Do I Migrate ECS Data Across Regions Using CSBS?
- Which Time Zone Is the Automatic Backup Time Based On?
- What Can I Do If a Backup Cannot Be Deleted?
- About Restoration
- Others
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About Concepts
- Troubleshooting
- Videos
- Glossary
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More Documents
-
User Guide (Paris and Amsterdam Regions)
- Service Overview
- Getting Started
- Management Operations
-
FAQs
- About Concepts
-
About Backup
- Does CSBS Support Backing Up All EVS Disks on an ECS?
- Do I Need to Stop the ECS Before Backing It Up?
- Can an ECS with Application Systems Be Backed Up?
- What Are the Minimum Backup Frequency and Maximum Number of Retained Backups Supported by CSBS?
- How Can I Distinguish Automatic Backups From Manual Backups?
- Does CSBS Support Cross-Region Backup for ECSs?
- About Restoration
- Others
- Troubleshooting Cases
- Change History
- API Reference (Paris and Amsterdam Regions)
-
User Guide (Paris and Amsterdam Regions)
- General Reference
On this page
Help Center/
Cloud Server Backup Service/
Troubleshooting/
Failed to Download or Install the Agent Required by Application-Consistent
Copied.
Failed to Download or Install the Agent Required by Application-Consistent
Symptom
The system displays a message indicating that the script cannot be downloaded or the Agent fails to be installed in Linux mode 2.
Possible Causes
- Cause 1: The DNS cannot resolve the obs.myhuaweicloud.com domain name.
- Cause 2: The OpenSSL version of the target ECS is too early.
Solution for Cause 1
Cause 1: The DNS cannot resolve the obs.myhuaweicloud.com domain name.
Manually change the DNS server address to a HUAWEI CLOUD private DNS server address. If the problem persists, try later or use the Linux mode 1 to install it.
Procedure (Linux)
- Log in to the ECS as user root.
- Run the vi /etc/resolv.conf command to edit the /etc/resolv.conf file. Add the DNS server IP address above the existing name server information, as shown in Figure 1.
The format is as follows:
- Press Esc, input :wq, and press Enter to save the changes and exit the vi editor.
- Run the following command to check whether the IP address is successfully added. If yes, the operation is complete.
cat /etc/resolv.conf
Procedure (Windows)
- Go to the ECS page and log in to the ECS running Windows Server 2012.
- Click This PC in the lower left corner.
- On the page that is displayed, right-click Network and choose Properties from the drop-down list. The Network and Sharing Center page is displayed, as shown in Figure 2. Click Local Area Connection.
- In the Activity area, select Properties. See Figure 3.
- In the Local Area Connection Properties dialog box that is displayed, select Internet Protocol Version 4 (TCP/IPv4) and click Properties. See Figure 4.
- In the dialog box that is displayed, select Use the following DNS server addresses: and configure DNS, as shown in Figure 5. After the configuration, click OK.
Solution for Cause 2
Cause 2: The OpenSSL version of the target server is too early.
- Use a remote management tool (such as PuTTY or Xshell) to connect to your ECS through the elastic IP address.
- Select the Agent version based on your needs, copy the command of installation mode 2 to the server, and change https to http in wget. Run the changed command as the root user:
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