Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-33005 Maximum Number of Concurrent Containers Requests Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-33005 Maximum Number of Concurrent Containers Requests Exceeds the Threshold

Alarm Description

The system checks the maximum number of concurrent Containers requests every 5 minutes and compares the number with the threshold. This alarm is generated when the maximum number of concurrent service requests exceeds the threshold.

This alarm is automatically cleared when the maximum number of concurrent Containers requests is less than or equal to the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

33005

Warning

Quality of service

Containers

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

ApplicationServiceName

Specifies the name of the application for which the alarm is generated.

Version

Specifies the version for which the alarm is generated.

Method

Specifies the method for generating the alarm.

IP

Specifies the IP address for which the alarm is generated.

Additional Information

Trigger Condition

Specifies the alarm triggering condition.

Impact on the System

If the maximum number of concurrent Containers requests is too large, the service provider rejects some requests. As a result, the service fails to be called.

Possible Causes

  • It takes a long time to process the service logic code.
  • The service volume is too large.

Handling Procedure

Check whether the service code processing time is too long.

  1. On FusionInsight Manager, choose Cluster > Services > Containers.
  2. Choose SGP Management > App Service List, and click the link of the service for which the alarm is generated to access the service status page.
  3. Check whether the provider's processing time is too long.

    • If yes, go to 4.
    • If no, go to 6.

  4. Check whether the processing time of user's upper-layer service logic code is too long.

    • If yes, optimize the upper-layer service logic code and execute 5.
    • If no, go to 6.

  5. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Check whether the service volume is too large.

  1. On FusionInsight Manager, choose Cluster > Services > Containers, click the SGP Management tab, and view charts Request Number Per Second and Response Time to check whether the data volume remains high.

    • If yes, go to 7.
    • If no, go to 9.

  2. Choose Cluster > Services > Containers, and click the Business Manager tab. Select the BLU that carries services. On the page that is displayed, click the BLU Instance tab and click Add Instance to add a BLU instance.
  3. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 9.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list and select Containers.
  3. Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the hosts to which the role belongs, and click OK.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 15 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.