Help Center> CodeArts TestPlan> FAQs> What Do I Do If No Test Case Exists in a Test Suite?
Updated on 2022-09-29 GMT+08:00

What Do I Do If No Test Case Exists in a Test Suite?

Symptom

When a test suite is executed, the following error information is displayed:

  • Manual test suite: "No test case exists in the test suite. Add a test case and try again."
  • API automation suite: "Test case cannot be empty."

Root Cause

The error information is displayed when a test suite contains no test case.

Solution

  1. Click the name of the test suite that reports the error. The Details page is displayed.
  2. Click Add Case to add a test case to be executed for the current test suite.
  3. After a test case is added, run the test suite again.