Help Center/ Server Migration Service/ FAQs/ Migration or Synchronization Failures/ How Do I Fix Error SMS.3805 When a Migration Drill Fails?
Updated on 2025-07-31 GMT+08:00

How Do I Fix Error SMS.3805 When a Migration Drill Fails?

Symptom

The migration drill failed, and the error message "SMS.3805 Connection to port 22 of target server timed out" was displayed.

Possible Causes

A migration drill checks the overall migration process in advance to ensure smooth operations across both the data and service planes. It also verifies network stability and connectivity. The results help identify and resolve potential issues early, significantly improving the success rate of one-time migrations.

This error typically occurs when the source and target servers are disconnected during migration. Specifically, the source server is unable to connect to the target server over port 22 for data transfer due to a timeout, which manifests as an OpenSSH "connect timeout" error.

Solution

  1. Test the network connectivity between the source and target servers.

    • If the source server runs Windows, run the following Telnet command on the source server:
      telnet <target-server-IP-address> <port 22>
      For example, if the target server's IP address is 192.168.1.x, run the following command:
      telnet 192.168.1.x 22

      If the connection cannot be set up, the network is disconnected. In this case, perform 2 to check the network settings, firewall settings, and SMS-Agent version.

    • If the source server runs Linux, run the following SSH command on the source server:
      ssh <target-server-IP-address> <port 22>
      For example, if the target server's IP address is 192.168.1.x, run the following command:
      ssh 192.168.1.x 22

      If the error message "Connection refused" is displayed or the connection times out, the network is disconnected. In this case, perform 2 to check the network settings, firewall settings, and SMS-Agent version.

  2. Check the network settings, firewall settings, and SMS-Agent version.

    • Check whether the network between the source server and the target server is correctly configured.

      Check whether the target server's IP address has changed and confirm the migration task uses the right target server.

      To ensure a successful migration, the target server must be accessible from the source server. For details about how to configure the network, see Network Configurations for Different Migration Scenarios.

    • Check whether the connection from the source server to the target server is blocked by any firewalls, security groups, ACL rules, or security software.

      Check the firewall, ACL, and security group settings of the source and target servers. Confirm that the source server can access the target server over the required ports (ports 22, 8899, and 8900 for Windows migration; port 22 for Linux file-level migration; and ports 22 and 8900 for Linux block-level migration). Then, perform the migration drill again.

      Check whether security software on the source server blocks the connection. If so, disable the software and try again.

    • Check the SMS-Agent version.

      On the Servers page of the SMS console, click the source server name. On the displayed page, open the Source Info tab and view the SMS-Agent version. The SMS-Agent version must be 25.5.0 or later. If the SMS-Agent version does not meet this requirement, download and install the latest SMS-Agent on the source server and create a migration task again.