Help Center> Server Migration Service> FAQs> Known Errors and Solutions> SMS.2802 Failed to Connect to the Target Server. Check Whether Its IP Address Is Reachable and Port 8899 Is Enabled
Updated on 2024-03-29 GMT+08:00

SMS.2802 Failed to Connect to the Target Server. Check Whether Its IP Address Is Reachable and Port 8899 Is Enabled

Symptom

The target server could not be accessed, and the following message was displayed: SMS.2802 Failed to connect to the target server. Check whether its IP address is reachable and port 8899 is enabled.

Possible Causes

For a Windows migration, ports 8899 must be enabled on the target server for communicating with SMS and the source server. If communications cannot be established, this error occurs. You can locate the fault by:

Checking Whether the Source Server Can Connect to the Target Server

  1. Log in to the source server.
  2. Run telnetTarget sever IP address 8899.

    • If the IP address is reachable, click Start on the SMS console to continue the migration.
    • If the Telnet connection fails, check the DNS, firewall, security group, and local network settings of the source and target servers.

Checking Whether Port 8899 Is Enabled in the Security Group of the Target Server

  1. Log in to the SMS console.
  2. In the service list, under Compute, choose Elastic Cloud Server. In the ECS list, click the name of the target ECS.
  3. On the ECS details page, click the Security Groups tab. Check whether port 8899 is opened and the source IP address is specified correctly.

    If port 8899 is not opened, add an inbound rule for the port. If such a rule exists but the source IP address is not 0.0.0.0/0 or the IP address of the source server, change it to 0.0.0.0/0.

    For detailed instructions, see How Do I Configure Security Group Rules for Target Servers?

Checking Whether Port 8899 Is Allowed in the Network ACL of the Target Server

  1. Log in to the management console.
  2. Check whether the subnet of the target server is associated with a network ACL.

    If a network ACL has been associated, and there is an inbound rule configured for port 8899, change the action to Allow.

    For details, see Modifying a Network ACL Rule.

Checking Whether the Peagent on the Target Server Is Running Properly

After confirming the network is normal, forcibly restart the target server. Wait for about 3 minutes and start the migration again.

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