How Do I Fix Error "INTERNAL ERROR: cannot create temporary directory!" When I Start the Agent?
Symptom
When you started the SMS-Agent-Py2, you received error message "INTERNAL ERROR: cannot create temporary directory!"
Possible Causes
Some files will be generated in a temp directory of the C: drive when you install the Agent. This error occurs if the available space of the C: drive is insufficient or if you do not have the permission to create a temp directory there.
Solutions
- Check how much space is available on the C: drive. If there is not enough space, clean up the drive.
- Check whether you can create a temp directory on the C: drive. You may need to obtain write permissions.
Agent Installation and Startup FAQs
- How Do I Download and Install the Agent on Source Servers?
- What Can I Do If I Fail to Download the Agent Installation File?
- How Do I Verify the Integrity of the Agent Installation File?
- Why Wasn't My Source Server Added to the SMS Console After I Configured the Agent?
- How Do I Configure Certificate Verification in the SMS-Agent Configuration File?
- Where Can I Find the Agent Run Logs?
- Why Is My Target Server Locked During the Migration?
- How Do I Unlock a Target Server Manually?
- How Do I Resolve Error "The application cannot be started due to incorrect parallel configuration" When I Start the Agent?
- Why Does the Agent Not Start the First Time I Launch It?
- Why Does the Windows Agent Executable Not Run When I Double-Click It?
- How Do I Fix Error "INTERNAL ERROR: cannot create temporary directory!" When I Start the Agent?
- How Do I Troubleshoot Failures of Pasting the AK/SK Pair When I Start the Agent (Python 2)?
- How Do I Resolve Error "utf-8 codec can't decode byte 0xce in position0: invalid continuation byte" When I Start the Agent?
- How Do I Restart the Agent?
- How Do I Fix Agent Startup Failures Due to Insufficient Space in /tmp on a Linux Source Server?
- How Do I Fix Error "Failed to start sms agent! 'disks'" When I Start the Agent on a Linux Source Server?
- How Do I Fix Error "Failed to obtain information about disk X" When I Start the Agent on a Linux Source Server?
- How Do I Choose When the System Asks Whether to Disable the Google Services Detected on My Source Server on the Google Cloud?
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbotmore