Help Center> Server Migration Service> FAQs> Agent Installation and Startup> How Do I Fix Agent Startup Failures Due to Insufficient Space in /tmp on a Linux Source Server?
Updated on 2023-01-16 GMT+08:00

How Do I Fix Agent Startup Failures Due to Insufficient Space in /tmp on a Linux Source Server?

Symptom

When you ran sh startup.sh to start the SMS Agent, the following message was displayed:

Failed to write all bytes for cffibackend.cpython-36m-x86_64-linux.gnu.so
fwrite: No space left on device

Possible Causes

When the Agent is being started, directories and files are generated in the /tmp directory on the source server. These files will occupy about 40 MB of space. You need to reserve more than 100 MB space for the /tmp directory.

Solution

  1. Log in to the source server.
  2. Run the df -lh command to check whether there is a volume mounted to the /tmp directory. If there is, check the available space for that volume.
  3. If the available space in the /tmp directory is insufficient for the mounted volume, perform either of the following operations:

    • Delete unnecessary files or expand the capacity of the volume mounted to the /tmp directory.
    • Run export TMPDIR=/home/user/tmpdir command (replace /home/user/tmpdir with a directory that meets the requirements) to change the cache directory.

Agent Installation and Startup FAQs

more