Help Center> ServiceStage> FAQs> Infrastructure> What Should I Do If the Service Registration Fails After IPv6 Is Enabled for the Exclusive Microservice Engine with Security Authentication Enabled?
Updated on 2023-07-14 GMT+08:00

What Should I Do If the Service Registration Fails After IPv6 Is Enabled for the Exclusive Microservice Engine with Security Authentication Enabled?

Symptom

A microservice developed based on Java Chassis is registered with the exclusive microservice engine with security authentication enabled. The microservice registry center address is the IPv4 address of the microservice engine registry center. The microservice can be successfully registered and started.

If the microservice registry center address is changed to the IPv6 address of the microservice engine registry center, the registration fails and the error "java.net.SocketException: Protocol family unavailable" is reported.

Possible Cause

If you select the VPC network with IPv6 enabled when creating an exclusive microservice engine, the engine supports the IPv6 network. If the service is deployed using a container through an IPv6 network segment, the IPv6 dual-stack function must be enabled for the selected CCE cluster.

If IPv6 is not enabled for the selected cluster, the service network is disconnected, and the error "java.net.SocketException: Protocol family unavailable" is reported.

Solution

  1. Modify the environment where the microservice application is deployed by adding a CCE cluster with the IPv6 dual-stack function enabled.

    Modify the environment. For details, see Modifying an Environment.

  2. Redeploy the application. For details, see Creating and Deploying Components.

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