Help Center> Migration Center> FAQs> Product Consultation> How Do I Fix the Error "Failed to access IAM. Check the current user's IAM permissions"?
Updated on 2023-11-09 GMT+08:00

How Do I Fix the Error "Failed to access IAM. Check the current user's IAM permissions"?

Description

When you used the TCO analysis or resource recommendation function, the message "Failed to access IAM. Check the current user's IAM permissions" was displayed.

Possible Causes

The login account does not have the IAM ReadOnly permission.

Solution

Assign the IAM ReadOnly permission to your account. For details, see Assigning Permissions to an IAM User.

Product Consultation FAQs

more