Help Center/ DataArts Studio/ FAQs/ DataArts Factory/ What Should I Do If the Agency List Fails to Be Obtained During Agency Configuration?
Updated on 2024-08-30 GMT+08:00

What Should I Do If the Agency List Fails to Be Obtained During Agency Configuration?

Possible Causes

If error message "Policy doesn't allow iam:agencies:listAgencies to be performed." is displayed when you are creating a workspace-level or job-level agency, you may lack the required permissions.

Solution

Add the View Agency List policy for the current user.

You can create a custom policy (query the agency list based on specified conditions) and assign it to a user group for refined access control.

  1. Log in to the HUAWEI CLOUD management console.
  2. On the management console, hover the mouse pointer over the username in the upper right corner, and choose Identity and Access Management from the drop-down list.
  3. In the navigation pane, choose Permissions > Roles. Then, click Create Custom Policy.
  4. Enter a policy name.

    Figure 1 Policy name

  5. Set Scope based on the region where the service is deployed. In this example, you need to grant IAM the permission to query the agency list based on specified conditions. As IAM is a global service, select Global services for Scope.
  6. Select Visual editor for Policy View.
  7. Configure a policy in Policy Content.

    1. Select Allow.
    2. Select Identity and Access Management (IAM) for Select service.
    3. Select iam:agencies:listAgencies for Select action.

  8. Click OK.
  9. Add the policy defined in 7 to the group to which the current user belongs. For details, see Creating a User Group and Granting Permissions.
  10. In the navigation pane on the left, choose Agencies. Locate the target agency, click Authorize in the Operation column, add the created custom policy to the agency, and click OK.

    The current user can log out of the system and then log in again to obtain the agency list.