Help Center/ Cloud Container Engine/ FAQs/ Permissions/ How to Resolve Agency Creation or Verification Errors?
Updated on 2026-05-25 GMT+08:00

How to Resolve Agency Creation or Verification Errors?

Error Message: "The number of agencies has reached the maximum"

Possible Cause

Your account has reached the maximum number of allowed agencies.

Solution

Contact IAM to request an increase in the agency quota.

Error Message: "Policy doesn't allow iam:agencies:createAgency to be performed"

Possible Cause

The user does not have the required permissions to create or authorize an agency.

Solution

Assign the following IAM operation permissions to the user:

  • iam:agencies:createAgency for creating an agency
  • iam:permissions:revokeRoleFromAgencyOnProject: for removing permissions of an agency for a region-specific project
  • iam:permissions:grantRoleToAgencyOnProject: for granting permissions to an agency for a region-specific project
  • iam:permissions:grantRoleToAgency: for granting permissions to an agency
  • iam:roles:createRole for creating a custom policy
  • iam:roles:updateRole for modifying a custom policy
  • iam:roles:listRoles for listing permissions
  • iam:agencies:listAgencies for querying agencies based on specified conditions

For details about how to customize cloud service operation permissions, see Example Custom Policies.

Error Message: agency ... not exist or agency type not supported

Possible Cause

The specified agency does not exist, or the agency type is not supported.

Solution

  1. Check whether the agency exists.

    1. Log in to the IAM console and choose Agencies from the navigation pane.
    2. Check whether an agency with the specified name exists.

  2. Check whether the current agency is trusted. Trust agencies are created via the new IAM console. CCE does not support trust agencies. Use a different agency type.