What Should I Do If Creating an Agency Fails?
Error Message: "The number of agencies has reached the maximum"
Possible Cause
Your account has reached the maximum number of allowed agencies.
Solution
Contact IAM to request an increase in the agency quota.
Error Message: "Policy doesn't allow iam:agencies:createAgency to be performed"
Possible Cause
The user does not have the required permissions to create or authorize an agency.
Solution
Assign the following IAM operation permissions to the user:
- iam:agencies:createAgency: for creating an agency
- iam:permissions:revokeRoleFromAgencyOnProject: for removing permissions of an agency for a region-specific project
- iam:permissions:grantRoleToAgencyOnProject: for granting permissions to an agency for a region-specific project
- iam:roles:createRole: for creating a custom policy
- iam:roles:updateRole: for modifying a custom policy
For details about how to customize cloud service operation permissions, see Example Custom Policies.
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