Help Center> Cloud Container Engine> FAQs> Node> Node Running> What Should I Do If a Node Does Not Synchronize with the NTP Clock Source?
Updated on 2024-05-10 GMT+08:00

What Should I Do If a Node Does Not Synchronize with the NTP Clock Source?

Symptom

In special scenarios, if the ntpd on a node cannot access the NTP server for a long time, the time offset may be too large and cannot be automatically restored.

Problem Detection

You can detect the problem by installing the CCE Node Problem Detector (npd) add-on that has the node time synchronization check item. For details, see CCE Node Problem Detector.

Possible Causes

This is a known issue on nodes running EulerOS or CentOS. Nodes running other types of OSs are not affected by this issue.

This issue has been resolved in clusters of v1.19.16-r7, v1.21.9-r10, and v1.23.7-r10.

Solution

  • If your cluster version is v1.19.16-r7, v1.21.9-r10, v1.23.7-r10, or later, the node of this version has been switched to chronyd for time synchronization. Reset the node OS to the latest version to rectify the fault.
  • If your cluster version does not meet the requirements, you are advised to upgrade the cluster to v1.19.16-r7, v1.21.9-r10, v1.23.7-r10, or later, and then reset the node OS to the latest version.

Node Running FAQs

more