Help Center> Application Operations Management> FAQs (1.0)> Usage FAQs> Why Can't I See Any Logs on the Console?
Updated on 2023-11-20 GMT+08:00

Why Can't I See Any Logs on the Console?

Symptom

No logs are displayed on the AOM console.

Possible Causes

  • No ICAgent has been installed.
  • The log collection path is incorrect.
  • Log collection has not been enabled on the AOM console.
  • The Continue to Collect Logs When the Free Quota Is Exceeded option has not been enabled on the AOM console.
  • Your account is in arrears.
  • The rate of writing logs into log streams or the length of single-line logs exceeds the upper limit.

Solution

  • To install an ICAgent, do as follows:
    1. In the navigation pane, choose Configuration Management > Agent Management.
    2. Select a cluster and click Install ICAgent. In the dialog box that is displayed, click OK.

      Wait until the ICAgent status changes to Running, indicating that the ICAgent is successfully installed.

  • If the collection path is set to a directory, for example, /var/logs/, only .log, .trace, and .out files in the directory are collected. If the collection path is set to a text file name, the corresponding file is directly collected. For more details, see Configuring Log Collection Paths.
  • Log in to the AOM console. In the navigation pane, choose Configuration Management > Log Configuration. On the Log Switch tab page, enable log collection.
  • You are billed based on log usage, including log read/write, log indexing, and log retention. If Continue to Collect Logs When the Free Quota Is Exceeded is disabled, log collection will be stopped when the free quota is used up. Log read/write and indexing will no longer be available. No fees will be incurred for log read/write and indexing. If necessary, enable Continue to Collect Logs When the Free Quota Is Exceeded. The procedure is as follows:

    Log in to the AOM console. In the navigation pane, choose Configuration Management > Log Configuration. On the Quota Management tab page, enable Continue to Collect Logs When the Free Quota Is Exceeded.

  • Top up your account if your account is in arrears. For details, see Making Repayments (Prepaid Direct Customers).
  • Use the Chrome or Firefox browser to query logs.
  • If the issue persists after you have tried the methods above, submit a service ticket.

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