ALM-12087 System Is in the Upgrade Observation Period
Description
The system checks whether it is in the upgrade observation period at 00:00 every day and checks whether the duration that it has been in the upgrade observation state exceeds the preset upgrade observation period, 10 days by default. This alarm is generated when the system is in the upgrade observation period and the duration that the system has been in the upgrade observation state exceeds the preset period (10 days by default). This alarm is automatically cleared if the system exits the upgrade observation period after the user performs a rollback or submission.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
12087 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Upgrade Observation Period (Days) |
Specifies the days that the system is in the upgrade observation period. |
Impact on the System
During the upgrade observation period, do not add or delete users, instances, roles, services, hosts, or resource pools that affect the management topology.
Possible Causes
The upgrade task is not submitted a specified period of time (10 days by default) after the system upgrade.
Procedure
Check whether the system is in the upgrade observation period.
- Log in to the active management node as user root.
- Run the following commands to switch to user omm and log in to the omm database:
su - omm
gsql -U omm -W omm database password -p 20015
- Run the select * from OM_CLUSTERS command to view cluster information.
- Check whether the value of upgradObservationPeriod isON is true, as shown in Figure 1.
- If it is, the system is in the upgrade observation period. Use the UpdateTool to submit the upgrade task. For details, see the upgrade guide of the corresponding version.
- If it is not, go to 6.
- In the early morning of the next day, check whether this alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 6.
Collect fault information.
- On the FusionInsight Manager portal, choose O&M > Log > Download.
- Select Controller from the Service and click OK.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected log information.
Alarm Clearing
This alarm will be automatically cleared after the fault is rectified.
Related Information
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot