Updated on 2026-09-24 GMT+08:00

ALM-12085 Service Audit Log Dump Failure

Alarm Description

The system dumps service audit logs at 03:00 every day and stores them on the OMS node. This alarm is generated when the dump fails. This alarm is cleared when the next dump succeeds.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

12085

Minor

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

If the component audit logs fail to be dumped and the audit logs are aged locally, the audit logs cannot be retrieved, affecting the service analysis and troubleshooting of the component.

Possible Causes

  • The service audit logs are oversized.
  • The OMS backup storage space is insufficient.
  • The storage space of a host where the service is located is insufficient.

Handling Procedure

Check whether the service audit logs are oversized.

  1. In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the IP address of the host for which the alarm is generated and additional information.
  2. Log in to the host where the alarm is generated as user root.
  3. Run the vi ${BIGDATA_LOG_HOME}/controller/scriptlog/getLogs.log command to check whether there is the keyword "LOG SIZE is more than 5000MB."

  4. Check whether the oversized service audit logs are caused by exceptions.

The OMS backup storage space is insufficient.

  1. Run the vi ${BIGDATA_LOG_HOME}/controller/scriptlog/getLogs.log command to check whether there is the keyword "Collect log failed, too many logs on."

    • If yes, obtain the host IP address following the keyword "Collect log failed, too many logs on" and go to Step 6.
    • If no, go to Step 11.

  2. Log in to the host with the IP address obtained in Step 5 as user root.
  3. Run the vi ${BIGDATA_LOG_HOME}/nodeagent/scriptlog/collectLog.log command to check whether there is the keyword "log size exceeds".

  4. Check whether the additional information of the alarm contains the keyword "no enough space".

  5. Perform the following operations to expand the disk capacity (only for MRS 3.1.2 and earlier versions) or reduce the maximum number of audit log backups:

    • Expand the capacity of the OMS node.
    • Run the following command to decrease the value of MAX_NUM_BK_AUDITLOG, which specifies the maximum number of audit log backups:

      vi ${CONTROLLER_HOME}/etc/om/componentsauditlog.properties

  6. Wait until the next execution period (03:00) and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to Step 11.

Check whether the space of the host where the service is located is insufficient.

  1. Run the vi ${BIGDATA_LOG_HOME}/controller/scriptlog/getLogs.log command to check whether there is the keyword "Collect log failed, no enough space on hostIp."

    • If yes, obtain the IP address of the abnormal host and go to Step 12.
    • If no, go to Step 15.

  2. Log in to the host with the IP address obtained as user root, and run the df "$BIGDATA_HOME/tmp" -lP | tail -1 | awk '{print ($4/1024)}' command to obtain the remaining space of the host log directory. Check whether the value is less than 1000 MB.

  3. Expand the capacity of the node
  4. Wait until the next execution period (03:00) and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to Step 15.

Collect fault information.

  1. On FusionInsight Manager, choose O&M > Log > Download.
  2. Select Controller for Service and click OK.
  3. Click in the upper right corner, set Start Date and End Date for log collection to 10 minutes before and after the alarm generation time, respectively, and click Download.
  4. Send the collected fault logs to O&M personnel for help.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None