An Elasticsearch Cluster Reports Error Message "unassigned shards all indices"
Symptom
An Elasticsearch cluster reports error message unassigned shards all indices and the cluster status is red.
Possible Causes
Unallocated shards exist in the current cluster.
Solution
- Log in to Kibana.
- Log in to the CSS management console.
- In the navigation pane on the left, choose Clusters > Elasticsearch.
- In the cluster list, find the target cluster, and click Kibana in the Operation column to log in to the Kibana console.
- In the left navigation pane, choose Dev Tools.
The left part of the console is the command input box, and the triangle icon in its upper-right corner is the execution button. The right part shows the execution result.
- Run the following command to re-allocate unallocated shards:
POST /_cluster/reroute?retry_failed=true
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot