ALM-12027 Host PID Usage Exceeds the Threshold
Alarm Description
The system checks the PID usage every 30 seconds and compares the actual PID usage with the default PID usage threshold. This alarm is generated when the system detects that the PID usage exceeds the threshold.
When the Trigger Count is 1, this alarm is cleared when the PID usage is less than or equal to the threshold. When the Trigger Count is greater than 1, this alarm is cleared when the PID usage is less than or equal to 90% of the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
12027 |
Critical (default threshold: 95%) Major (default threshold: 90%) |
Environment |
FusionInsight Manager |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Trigger Condition |
Specifies the triggering condition for which the alarm is generated. |
Impact on the System
Service failure: If the PID usage of the host is too high, PIDs cannot be allocated to new service processes. As a result, jobs may fail to be executed.
Possible Causes
Too many processes are running on the node. You need to increase the value of pid_max.
Handling Procedure
Increase the value of pid_max.
- In the alarm list on FusionInsight Manager, click in the row where the alarm is located to view the alarm host address in the alarm details.
- Log in to the host where the alarm is generated as user root.
- Run the cat /proc/sys/kernel/pid_maxcommand to check the value of pid_max.
- If the PID usage exceeds the threshold, run the command echo new value > /proc/sys/kernel/pid_max to enlarge the value of pid_max.
Example: echo 65536 > /proc/sys/kernel/pid_max
The maximum value of pid_max is as follows:
- On 32-bit systems: 32768
- On 64-bit systems: 4194304 (2^22)
- Wait for 5 minutes, and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect fault information.
- On the FusionInsight Manager home page of the active cluster, choose O&M > Log > Download.
- Select all services from the Service and click OK.
- Click the edit button in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M engineers and send the collected log information.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None.
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