What Should I Do If My Data Exceeds the Available Storage of an RDS for MySQL Instance?
Symptom
There is not enough storage available for an RDS instance and the instance becomes read-only, so applications cannot write any data to the instance.
Causes
- Increased workload data
- Too much data being stored
- Too many RDS for MySQL binlogs generated due to a large number of transactions and write operations
- Too many temporary files generated due to a large number of sorting queries executed by applications
Solution
- For insufficient storage caused by increased workload data, scale up storage space.
If the original storage has reached the maximum, upgrade the specifications first.
For instances using cloud disks, you can configure autoscaling so that RDS can autoscale your storage when the storage usage reaches the specified threshold.
- If too much data is stored, delete unnecessary historical data.
- If the instance becomes read-only, you need to contact customer service by submitting a service ticket to cancel the read-only status first.
- Check the top 50 databases and tables with large physical files and identify the historical table data that can be deleted. For details, see Storage Analysis.
- To clear up space, you can optimize tables with a high fragmentation rate during off-peak hours.
To delete data of an entire table, run DROP or TRUNCATE. To delete part of table data, run DELETE and OPTIMIZE TABLE.
- If binlog files occupy too much space, clear local binlogs.
- If temporary files generated by sorting queries occupy too much storage space, optimize your SQL statements.
You can query slow query logs and top SQL statements, and analyze and optimize the problematic SQL statements.
- Subscribe to daily health reports to obtain SQL and performance analysis results, including slow SQL analysis, all SQL analysis, performance & storage analysis, and performance metric trend charts. You can receive a diagnosis report if there are any risks detected.
For details, see Daily Reports.
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