What Should I Do If My RDS for PostgreSQL Instance Fails to Be Connected Due to Client Problems?
Troubleshoot RDS for PostgreSQL connection failures caused by a client problem by checking the following items:
- ECS Security Policy
In Windows, check whether the RDS for PostgreSQL instance port is enabled in the Windows security policy. In Linux, run iptables to check the firewall and port allowlist.
- Application Configuration
Check whether the connection address, port parameter configuration, and JDBC connection parameter configuration are correct.
- Username or Password
Check whether the username or password is correct if an error similar to the following occurs during RDS DB connection:
FATAL: Invalid username/password,login denied.
What is your overall rating for this page?
Thank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot
