ALM-45277 RangerAdmin Heap Memory Usage Exceeds the Threshold
Description
The system checks the heap memory usage of the RangerAdmin service every 60 seconds. This alarm is generated when the system detects that the heap memory usage of the RangerAdmin instance exceeds the threshold (95% of the maximum memory) for 10 consecutive times. This alarm is cleared when the heap memory usage is less than the threshold.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
45277 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
Heap memory overflow may cause service breakdown.
Possible Causes
The heap memory usage of the RangerAdmin instance is high or the heap memory is improperly allocated.
Procedure
Check the heap memory usage.
- On FusionInsight Manager, choose O&M > Alarm > Alarms > ALM-45277 RangerAdmin Heap Memory Usage Exceeds the Threshold. Check the location information of the alarm and view the host name of the instance for which the alarm is generated.
- On FusionInsight Manager, choose Cluster > Services > Ranger > Instance. Select the role corresponding to the host name of the instance for which the alarm is generated. Click the drop-down list in the upper right corner of the chart area and choose Customize > CPU and Memory > RangerAdmin Heap Memory Usage. Click OK.
- Check whether the heap memory used by RangerAdmin reaches the threshold (95% of the maximum heap memory by default).
- On FusionInsight Manager, choose Cluster > Services > Ranger > Instance > RangerAdmin > Instance Configuration. Click All Configurations, and choose RangerAdmin > System. Increase the value of -Xmx in the GC_OPTS parameter based on the site requirements and save the configuration.
If this alarm is generated, the heap memory configured for RangerAdmin cannot meet the heap memory required by the RangerAdmin process. You are advised to check the heap memory usage of RangerAdmin and change the value of -Xmx in GC_OPTS to the twice of the heap memory used by RangerAdmin. The value can be changed based on the actual service scenario. For details, see 2.
- Restart the affected services or instances and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect the fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Ranger for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearing
This alarm is automatically cleared after the fault is rectified.
Related Information
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot