Help Center/ Elastic Cloud Server/ FAQs/ ECS Failure FAQ/ Why Is My Windows ECS Muted?
Updated on 2024-09-29 GMT+08:00

Why Is My Windows ECS Muted?

Symptom

You cannot play audio files on a Windows ECS that is remotely accessed using MSTSC.

Constraints

This section applies only to ECSs running Windows Server 2008 R2 or Windows Server 2016.

Possible Causes

The audio function is disabled on Windows ECSs by default. As a result, audio files cannot be played on them. To enable the audio function, perform the operations described in this section.

Step 1: Enable Windows Audio

Enable Windows audio and set it to run automatically.

  1. Start the Run dialog box.
  2. Enter services.msc to access the service management console.
  3. Find Windows Audio and set it as follows:
    • Startup type: Automatic
    • Service status: Start

    The following figure uses Windows Server 2012 as an example.

  4. Disable the remote connection.

Step 2: Enable Audio and Video Playback

The method of enabling audio and video playback varies depending on the ECS OS.

Windows Server 2008

  1. Enable RDP-TCP Audio and video playback and Audio recording.

    1. Log in to the Remote Desktop Session Host Configuration management console.
      1. Choose Start > Control Panel.
      2. In the upper right corner of the page, choose Category for View by.
      3. Choose System and Security > Administrative Tools > Remote Desktop Services > Remote Desktop Session Host Configuration.
    2. Deselect Audio and video playback and Audio recording.

      In the Connections pane, double-click RDP-Tcp. In the RDP-Tcp Properties dialog box, click the Client Settings tab and deselect Audio and video playback and Audio recording.

      Figure 1 Remote Desktop Session Host Configuration
    3. Click OK to enable the audio function.

  2. Click Send CtrlAltDel to restart the ECS and log in to it.
  3. Enable the audio service.

    Figure 2 Enabling the audio service

  4. Play an audio file to verify the service.

Windows Server 2012

  1. Start the Run dialog box.
  2. Run the gpedit.msc command to start Local Group Policy Editor.

  3. Choose Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection. Then, enable Allow audio and video playback redirection.
  4. Select Enabled and click Apply.

    Retain the default settings of MSTSC.

  5. Run the following command to update the group policy:

    gpupdate

Step 3: Configure Remote Audio Settings

Start the local remote desktop software MSTSC, choose Options > Local Resources, and click Settings in Remote audio. Then, select Play on this computer in Remote audio playback and click OK.

Log in to the ECS using MSTSC and check whether audio files can be played properly.