Help Center/ Elastic Cloud Server/ FAQs/ ECS Creation/ What Can I Do If I Cannot Find My ECSs?
Updated on 2025-11-18 GMT+08:00

What Can I Do If I Cannot Find My ECSs?

Symptom

You cannot find your purchased ECSs after logging in to the console.

Possible Causes

  • The ECSs are not in the selected region.
  • The yearly/monthly ECSs have expired, or the pay-per-use ECSs have been deleted due to arrears.

Solution

Method 1: Change the region.

  1. Log in to the management console.
  2. Select the region in which you created your ECS.
    Figure 1 Changing a region on the management console homepage

Method 2: View resource details on the My Resources page.

  1. Log in to the management console.
  1. On the right of the top navigation bar of the management console, choose Resources > My Resources.
    Figure 2 My Resources
  2. On the My Resources page, view resource details.
    • Click a resource type to display all resources of the resource type in the list.
    • Click a region to view all resources in the region.
    Figure 3 Resource list

Method 3: View historical resources in Billing Center.

This method is used only to view historical resources that have been unsubscribed from or deleted. For unsubscribed or deleted resources, if they are not backed up, their data cannot be restored.

  • Yearly/Monthly resources
    1. Log in to the Billing Center console.
    1. In the navigation pane on the left, choose Orders > My Orders.
    2. On the My Orders page, view yearly/monthly resources.

      You can filter resources by time period, product type, or order number.

  • Pay-per-use resources
    1. Log in to the Billing Center console.
    1. In the navigation pane on the left, choose Billing > Bill Details.
    2. Set Data Period to Details to view pay-per-use resources.

      You can filter resources using attributes in the search box.