更新时间:2023-09-07 GMT+08:00
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Agent状态异常应如何处理?

Agent状态主要分为以下三种,若Agent的运行状态为“未安装”或者“离线”时,可能是Agent与服务器间通信异常。请参见本文进行排查。

  • 未安装:主机从未安装Agent,或Agent已安装但未成功启动。
  • 离线:Agent与服务器通信异常,主机中的Agent已被删除,或非华为云主机离线。
  • 在线:主机内的Agent运行正常。

可能的原因

  • 网络故障。

    主机中的Agent和云端防护中心出现异常,如网卡故障、IP地址异变及带宽较低。

  • Agent进程异常。
  • 安装Agent后,不会立即生效,需要等待3~5分钟左右控制台才会刷新。

处理方法

  1. 排查网络故障。

    请确保您的云服务器所属安全组出方向设置允许访问100.125.0.0/16网段的443端口,确保云服务器能正常访问网络。

    待网络恢复正常后:
    • 若Agent状态为“在线”,则故障清除。
    • 若Agent状态仍为“未安装”或者“离线”,请执行步骤 2

  2. 若长时间Agent状态仍为“未安装”或者“离线”,可能是Agent进程异常,需要登录主机,重启Agent进程。

    • Windows操作系统

      以管理员administrator权限登录主机,完成重启Agent。

      图1 重启Windows Agent
    • Linux操作系统

      请以root用户在命令行终端执行以下命令,完成重启Agent。

      service hostguard restart

      若回显以下信息,则表示重启成功。若无回显信息,请卸载Agent,重新安装Agent
      root@HSS-Ubuntu32:~#service hostguard restart
      Stopping Hostguard...
      Hostguard stopped
      Hostguard restarting...
      Hostguard is running

    重启进程后等待约2分钟:

    • 若Agent状态为“在线”,则故障清除。
    • 若Agent状态仍为“未安装”或者“离线”,请卸载Agent,重新安装Agent

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