更新时间:2025-12-29 GMT+08:00
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节点插件状态离线问题排查

问题现象

操作系统控制台中使用"添加节点"功能后,节点插件状态显示“离线”。

可能原因

  1. 节点未开机

    在弹性云服务器控制台的云服务列表中,搜索离线节点名称,查看节点状态,如果节点处于关机状态,需要对节点进行开机操作。

  2. 插件未安装或未运行

    使用root用户,登录服务器节点,执行如下命令查询插件运行状态。

    systemctl status hce-agent

    如果如下图显示服务不存在,可以在节点管理中删除节点后重新添加。

    如果如下图显示服务状态为inactive,可以在节点上执行“systemctl start hce-agent”命令手动启动插件。

  3. 网络未打通

    登录服务器节点,执行如下命令(使用当前区域的region_code替换${region_code}):

    curl https://hceos-agent.${region_code}.myhuaweicloud.com

    如果如下图显示无法解析域名,则需要购买VPC终端节点打通网络。

网络打通流程

  1. 使用拥有VPCEndpoint Administrator角色或者VPCEndpoint FullAccess权限的账号登录VPCEP控制台
  2. 选择“终端节点”,在上方搜索栏按照虚拟私有云名称筛选节点对应的虚拟私有云,检查是否存在名称为“com.myhuaweicloud.${region_code}.hceos”的终端节点服务,若不存在,则执行步骤3,否则跳过至步骤4

  3. 单击页面右上方的“购买终端节点”按钮,选择按名称查找服务,输入com.myhuaweicloud.${region_code}.hceos,并使用当前区域的region_code替换${region_code},单击“验证”,并按需选择子网、ipv4地址等选项,最后单击“立即购买”。购买完成后等待几分钟,若节点插件状态已在线,则问题已修复,结束步骤,否则继续执行步骤4

  4. 登录IAM控制台,进入统一身份认证服务,在左侧导航栏选择委托,查看是否存在名称为“hceos_agent_trust”,委托对象为“service.HCEOS”的信任委托,若不存在则跳过至步骤5,若存在,单击“hceos_agent_trust”,单击“授权记录”,查看是否存在“HCEOSAgentAccessPolicy”系统身份策略,若不存在,则执行步骤5

  5. 进入HCE控制台,在左侧导航栏选择系统管理,进一步选择节点管理,单击“添加节点”按钮,弹窗中单击确定,并在节点执行“systemctl restart hce-agent”。

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