ALM-24005 Data Transmission by Flume Is Abnormal (For MRS 2.x or Earlier)
Description
The alarm module monitors the capacity of Flume channels. This alarm is generated if the duration that a channel is full or the number of times that a source fails to send data to the channel exceeds the threshold.
Users can set the threshold as required by modifying the channelfullcount parameter.
This alarm is cleared after the Flume channel space is released.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
24005 |
Major |
Yes |
Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
ComponentType |
Specifies the component type for which the alarm is generated. |
ComponentName |
Specifies the component name for which the alarm is generated. |
Impact on the System
If the usage of the Flume channel continues to grow, the data transmission time increases. When the usage reaches 100%, the Flume agent process is suspended.
Possible Causes
- The Flume sink is faulty.
- The network is faulty.
Procedure
- Check whether the Flume sink is normal.
- Check whether the Flume sink is the HDFS type.
- On MRS Manager, check whether the ALM-14000 HDFS Service Unavailable alarm is reported and whether the HDFS service is stopped.
- Check whether the Flume sink is the HBase type.
- On MRS Manager, check whether the ALM-19000 HBase Service Unavailable alarm is reported and whether the HBase service is stopped.
- Check whether the Flume sink is the Kafka type.
- On MRS Manager, check whether the ALM-38000 Kafka Service Unavailable alarm is reported and whether the Kafka service is stopped.
- Go to the MRS cluster details page and click Components.
- Choose .
- Click the Flume instance of the faulty node and check whether the value of the Sink Speed Metrics is 0.
- If yes, go to 2.a.
- If no, no further action is required.
- Check the status of the network between the Flume sink and faulty node.
- Check whether the Flume sink is the Avro type.
- Log in to the host where the faulty node resides. Run the following command to switch to user root:
sudo su - root
- Run the ping Flume sink IP address command to check whether the Flume sink can be pinged.
- Contact the network administrator to repair the network.
- Wait for a while and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 3.
- Collect fault information.
- On MRS Manager, choose .
- Contact the O&M engineers and send the collected logs.
Related Information
N/A
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