ALM-19000 HBase Service Unavailable (For MRS 2.x or Earlier)
Description
The alarm module checks the HBase service status every 30 seconds. This alarm is generated when the HBase service is unavailable.
This alarm is cleared when the HBase service recovers.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
19000 |
Critical |
Yes |
Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
Operations cannot be performed, such as reading or writing data and creating tables.
Possible Causes
- ZooKeeper is abnormal.
- HDFS is abnormal.
- HBase is abnormal.
- The network is abnormal.
Procedure
- Check the ZooKeeper status.
- Go to the MRS cluster details page and click Components.
- In the service list, check whether the health status of ZooKeeper is Good.
- In the alarm list, check whether the alarm ALM-13000 ZooKeeper Service Unavailable exists.
- Rectify the fault by following the steps provided in ALM-13000 ZooKeeper Service Unavailable.
- Wait several minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 2.a.
- Check the HDFS status.
- Collect fault information.
- On MRS Manager, choose .
- Contact the O&M engineers and send the collected logs.
Reference
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.