ALM-50219 Length of the Queue in the Thread Pool for Query Execution Exceeds the Threshold
Alarm Description
The system checks the length of the waiting queue in the query execution thread pool every 30 seconds. This alarm is generated when the length exceeds the threshold (20 by default).
This alarm is cleared when the length of the waiting queue in the current query execution thread pool is less than the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
50219 |
Major |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
The task execution of the entire system becomes slow and blocked.
Possible Causes
Large tasks may block the task execution of the queue.
Handling Procedure
Check the execution status of tasks.
- On FusionInsight Manager, choose Cluster > Services > Doris. Click the Chart tab, select Connection from Chart Category in the left pane, and view the FE MySQL Port Connections chart. If the number of connections is large, click Instances, select the FE instance, and click the Chart tab. Select CPU and Memory from Chart Category and view the CPU Usage of FE chart. If the CPU usage is high, check the Time field in FE audit log /var/log/Bigdata/audit/doris/fe/fe.audit.log to collect statistics on the average task duration. If the value is also high, the alarm is caused by large concurrent tasks.
- After connecting to Doris, run the following command to check the queryTimeout value of the system:
show variables like 'query_timeout';
If the value is too large, run the set global query_timeout=xxx; command to shorten the timeout interval and block tasks that last for a long time.
- Log in to FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, and choose Doris > Queue > Queue Length of Query Execution Thread Pool (BE).
- Click the edit button next to Trigger Count, change the number based on site requirements, and click OK.
- Click Modify in the Operation column, change the alarm threshold based on site requirements, and click OK.
- Wait 10 minutes and check whether the alarm is automatically cleared.
- If yes, no further action is required.
- If no, go to 7.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Doris for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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