ALM-29015 Catalog Process Memory Usage Exceeds the Threshold
Alarm Description
The system checks the memory usage of the Catalog process every 30 seconds. This alarm is generated when the system detects that the memory usage exceeds the default threshold (80%).
This alarm is automatically cleared when the system detects that the memory usage of the process falls below the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
29015 |
Major |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
|
Additional Information |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
The memory usage is too high. Some query tasks may fail due to insufficient memory.
Possible Causes
The memory of the node instance is overused or the memory is inappropriately configured.
Handling Procedure
- On FusionInsight Manager, choose O&M > Alarm > Thresholds > Impala > CPU and Memory > Catalog Process Memory Usage (Impalad) and check the threshold.
- If the alarm threshold is smaller than 80%, increase the alarm threshold as required and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 3.
- If the threshold is greater than 80%, check whether a large number of concurrent query tasks exist when the alarm is generated. A large number of concurrent query tasks will cause the memory usage to increase sharply. After the tasks are complete, check whether the alarm is automatically cleared. During this period, some tasks may fail to be executed or may be canceled due to insufficient memory. In this case, try again.
If the memory usage always exceeds the threshold, the cluster capacity needs to be expanded.
- If yes, no further action is required.
- If no, go to 4.
Collect fault information.
- On FusionInsight Manager of the active or standby cluster, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Impala for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None
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