ALM-29014 Catalog FGC Time Exceeds the Threshold
Alarm Description
The system checks the FGC time of the Catalog service every 60 seconds. This alarm is generated when the FGC time exceeds the threshold (12 seconds) for five consecutive times. This alarm is cleared when the FGC time is less than or equal to the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
29014 |
Major |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
|
Additional Information |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
Data read and write are affected.
Possible Causes
The memory of the node instance is overused or the heap memory is inappropriately allocated, causing frequent occurrence of the GC process.
Handling Procedure
Check the GC time.
- Choose O&M > Alarm > Thresholds, click the name of the desired cluster, choose Impala > Process FGCT > Process FGCT of Catalog (Catalog), and check the threshold (12s by default).
- Log in to FusionInsight Manager, choose O&M > Alarm > Alarms, and check whether the alarm whose Alarm ID is 29014 exists in the alarm list.
- If yes, go to 3.
- If no, no further action is required.
- On FusionInsight Manager, choose Cluster > Impala, click the Instance tab, select the Catalog instance for which the alarm is generated, then click the Chart tab, locate the Process FGCT chart, and check whether the FGC time is greater than the threshold in 1.
- Choose O&M > Alarm > Thresholds, click the name of the desired cluster, choose Impala > Process FGCT > Process FGCT of Catalog (Catalog), and change the threshold to a value less than the time obtained in 3. Then, check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 5.
Collect fault information.
- On FusionInsight Manager of the active or standby cluster, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Impala for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None
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