Help Center/ Migration Center/ MgC Agent Usage Guide/ FAQs/ How Do I Fix the Error "The collector is not installed" When a Discovery Task Fails?
Updated on 2025-04-07 GMT+08:00

How Do I Fix the Error "The collector is not installed" When a Discovery Task Fails?

Symptom

After the MgC Agent and resource credential were associated, the deep collection failed, and the failure cause was "The collector is not installed."

Possible Causes

Possible causes are:

  • The MgC Agent server's capacity is too small to run the collector. The recommended specifications are 4 vCPUs and 8 GB of memory.
  • The collector was offline even though the MgC Agent server's capacity was sufficient.

Solutions

  • The MgC Agent server's capacity is too small.

    Upgrade the MgC Agent server's specifications or install the MgC Agent on a server with a larger capacity. Then perform a deep collection again.

  • The collector was offline.

    The following table lists the collectors integrated in the MgC Agent. The server collector is used as an example to explain the method, which applies to other collectors as well.

    Collector

    Collected Resource

    Process

    Installation Directory

    designcenter-collector-platform

    VMware-based private cloud platforms

    designcenter-collector-platform.exe

    <installation-path>\Edge\tools\plugins\collectors

    designcenter-collector-server

    Server

    designcenter-collector-server.exe

    rda-collector-kubernetes

    Container

    rda-collector-kubernetes.exe

    1. Go to the bin directory in the collector installation directory on the MgC Agent server, for example, C:\Edge\tools\plugins\collectors\designcenter-collector-server\bin.
    2. Double-click start.bat to start the server collector.

    3. Open Task Manager. On the details page, check the status of designcenter-collector-server.exe. If the status is Running, the collector is started.

    4. Return to the MgC console and click Collect in the Status column to collect the resource information again.