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CodeArts TestPlan
CodeArts TestPlan
- Service Overview
- Getting Started
-
User Guide
- Service Entries
- Testing Plan
- Testing Design
- Testing Management
-
Testing Case
- Introduction
- Test Case Library
- Manual Test Cases
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API Automation Test Cases
- Creating an API Automation Test Case
- Writing an API Automation Script
- Keyword Library
- API Keywords
- Combined Keywords
- Importing cURL to Generate Test Scripts
- Setting an API Request
- Setting a Test Checkpoint
- Setting Response Extraction
- Importing a Postman File
- Inserting Logic Control
- Setting Test Case Parameters
- Setting Environment Parameters
- Importing an API Automation Case
- Executing an API Automation Test Case
- Custom Automation Test Cases
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Advanced Configurations of API Automation
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Built-in Functions
- Binary Addition Operation
- Binary Subtraction Operation
- Binary Multiplication Operation
- Binary Division Operation
- Obtaining the Current Timestamp
- Obtaining a Specified Timestamp
- Converting a Date into a Timestamp
- Converting a Timestamp into a Date
- Timestamp Addition and Subtraction Operations
- Generating Base64 Encoding
- Generating SHA512 Encoding
- Generating an MD5 Hash Value
- Generating a Random Number in a Specified Range
- Generating a Random String of a Specified Length
- Generating a UUID
- Obtaining an Array via Reverse Index
- Obtaining the Element Values of an Array via Reverse Index
- Converting Uppercase Letters into Lowercase Letters
- Converting Lowercase Letters into Uppercase Letters
- Concatenating Strings
- Cutting Strings
- Advanced Extraction Types
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Built-in Functions
- Adding Test Cases in Batches
- Managing Test Cases in the Features Directory
- Test Cases and Requirements
- Test Cases and Defects
- Commenting on Test Cases
- Filtering Test Cases
- Customizing Columns to Be Displayed in the Test Case List
- Testing Execution
- Quality Report and Assessment
- Settings
- Roles and Operation Permissions
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FAQs
- What Do I Do If No Test Case Exists in a Test Suite?
- What Can I Do If I Do Not Have the Operation Permission?
- Why Am I See a Message Indicating that an API Automation Test Suite Is Being Executed or Queuing?
- What Do I Do If a Test Suite ID Does Not Exist?
- Why Can't I Download the Document in a Manual Test Case?
- What Do I Do If No Test Case Exists In a Test Plan
- Why Can't I Add Work Items of the Task Type When a Test Plan Is Created or Updated?
- What Do I Do If Test Cases Cannot Be Associated with Work Items of the Task Type?
- What Do I Do If the Test Case Completion Rate in the Test Report Is Lower Than 100%?
- Why Is the Status of Test Cases in a Test Plan Inconsistent with That in a Test Case Library?
- How Are Variables Passed Between Steps in API Automation Cases?
- How Do I Set Checkpoints for Test Procedures in API Automation Cases?
- Best Practices
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Why Can't I Download the Document in a Manual Test Case?
Updated on 2023-11-28 GMT+08:00
Symptom
During the download of the document associated with a manual test case, the following error information is displayed: "The request file does not exist."
Root Cause
- The document associated with the manual test case is deleted.
- Data is lost due to service exceptions.
Solution
- Click Documentation in the navigation pane.
- Click the Recycle Bin tab and search for the document name of the test case.
- If the document exists, click
to restore it.
- If the document does not exist, go to 3.
- If the document exists, click
- Return to the test case page, find the document that fails to be downloaded, click
to delete the document, and upload it again.
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