How Do I Fix Startup Failures of a Windows Target Server After the Migration?
Symptom
After the migration, the Windows target server cannot be started, even in safe mode.
Possible Causes
The KVM driver or KVM registry is missing.
Solutions
- Solution 1
- Create a temporary ECS in the same region and AZ as the target server. Detach the system disk from the target server and attach it to the temporary ECS.
- Check for the KVM driver.
- Check whether files viostor.sys and vioscsi.sys exist in the Windows\System32\drivers directory of the disk.
- Check whether files viostor.cat and vioscsi.cat are in the Windows\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} directory of the disk.
- Check whether files viostor.inf and vioscsi.inf are in the Windows\System32\drivers directory of the disk.
If any of the preceding files is missing, install the UVP VMTools upgrade package on the temporary ECS. Copy the desired file to the corresponding directory on the system disk of the target server.
The .sys, .cat, and .inf files are used in pairs. You need to copy a file pair, not just a single file.
- Check the registry.
- Open the Registry Editor and click HKEY_LOCAL_MACHINE in the navigation pane on the left.
- On the menu bar, choose File > Local Hive, locate registry C:\Windows\System32\config\SYSTEM, and change its name from SYSTEM to p2v.
- Open the registry and check whether entries p2v/ControlSet001/services/viostor and p2v/ControlSet001/services/vioscsi are there.
If they do not, manually add them to the registry by referring to the registry of the temporary ECS.
- Stop the temporary ECS, and attach the disk as the system disk to the target server. Then restart the target server.
- Method 2
Install the UVP VMTools on the source server and then perform a synchronization to the target server.
After the UVP Tools are installed, do not restart the source server, or the synchronization will fail.
Target Server Configuration and Launch FAQs
- What Are the Differences Between Target and Source Servers After the Migration?
- How Will the Authentication of a Target Server Change?
- How Do I Optimize a Windows Target Server After the Migration Is Complete?
- How Do I Fix the Error "SMS.1113 Failed to reconfigure partition details on the target server" When I Launch the Target Server?
- After a Windows Server Was Migrated, Why Is the Used Space of C: Drive Increased?
- How Do I Uninstall the SMS-Agent from the Source and Target Servers After the Migration Is Complete?
- How Do I Configure the Yum Repository for the Target Server After the Migration Is Complete?
- Why Is the File System Size Inconsistent Before and After the Migration?
- Why Can't I See Data Disks on a Windows Target Server After Migration?
- Why Can't a Windows Target Server Access the Internet After the Migration?
- Why Is the System Recovery Options Window Displayed When the Target Server Is Started?
- How Do I Fix a GRUB Error Because an XFS Volume Is Mounted to the /boot Partition?
- What Do I Do If a Target Server Fails to Be Created?
- How Do I Troubleshoot a MySQL Startup Failure on the Target Server After the Migration?
- How Do I Resolve Error "SELinux targeted" When I Start a Linux Target Server After the Migration Is Complete?
- Why Do the Agent Plug-ins from the Source Cloud Service Provider Exist on the Target Server After the Migration Is Complete?
- Why Is the Usable Memory (RAM) Less Than the Total Installed Memory on a Target Server Running 64-bit Windows?
- After the Migration Is Complete, Will Deleting the Target Server Configuration or Server Record Affect the Source or Target Server?
- How Do I Fix BSOD Errors When I Start a Windows Target Server After the Migration?
- How Do I Fix Startup Failures of a Windows Target Server After the Migration?
- If I Change the Password of the Source Server and Perform an Incremental Replication After the Full Migration Is Complete, Will the New Password Be Synchronized to the Target Server?
- What ECS Types Are Supported by SMS?
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