SMS.0212 Agent Restarted
Symptom
During a Windows migration, the migration task was abnormal, and the error message "SMS.0212 Agent restarted" was displayed.
Possible Causes
Possible causes include:
- The SMS-Agent program was manually restarted on the source server.
- After the source system account was deregistered, the SMS-Agent program exited and then was started again.
Solutions
- Solution 1
- In the server list on the SMS console, locate the server record and choose More > Delete Target Configuration in the Operation column.
- Configure a target server and start the migration again.
- Solution 2
- In the server list on the SMS console, locate the server record and choose More > Delete in the Operation column. Then delete the server record.
- Log in to the source server, stop the SMS-Agent program, and run it again.
If the SMS-Agent exits due to account deregistration, you are advised to use the SMS-Agent (Python 2) as a system service to perform the migration.
- Windows Agent (Python 3): Double-click SMS-Agent.exe in the SMS-Agent-Py3 directory to restart the SMS-Agent.
- Windows Agent (Python 2): Double-click restart.bat in the SMS-Agent-Py2 directory to restart the SMS-Agent.
- Enter the AK/SK pair for the Huawei Cloud account that you are migrating to and the SMS domain name.
- After the Agent is started, go to the SMS console and configure a target server again.
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