Help Center/ Distributed Message Service for RocketMQ/ FAQs/ Connection FAQs/ How Do I Handle Instance Connection Failure "RemotingTooMuchRequestException: sendDefaultImpl call timeout"
Updated on 2026-01-07 GMT+08:00

How Do I Handle Instance Connection Failure "RemotingTooMuchRequestException: sendDefaultImpl call timeout"

Symptom

Connecting to a RocketMQ instance failed. The error message is "RemotingTooMuchRequestException: sendDefaultImpl call timeout".

Possible Cause

The security group does not allow the service port.

Solution

  1. Log in to the RocketMQ console.
  2. Click a RocketMQ instance name to go to the instance overview page.
  3. Obtain the port in Allow Access To in the Network area.
  4. Click the security group name to go to the security group details page.
  5. Add an inbound rule to allow the port obtained in 3.