Help Center/ Scalable File Service/ Troubleshooting/ Mounting a File System Times Out
Updated on 2022-09-16 GMT+08:00

Mounting a File System Times Out

Symptom

When a file system is mounted to servers using the mount command, message timed out is displayed.

Possible Causes

  • Cause 1: The network status is not stable.
  • Cause 2: The network connection is abnormal.
  • Cause 3: The server where the file system is to be mounted runs Ubuntu18 or later.

Fault Diagnosis

After the network fault is excluded, run the mount command again.

Solution

  • Cause 1 and Cause 2: The network status is not stable or the network connection is abnormal.

    Re-mount the file system after the network issue is addressed.

    • If the patch is uninstalled successfully, no further action is required.
    • If the problem persists, see the solution for cause 3.
  • Cause 3: The server where the file system is to be mounted runs Ubuntu18 or later.
    1. Check whether the target server running Ubuntu18 or later uses a private image.
      • If yes, go to 3.
      • If no, go to 2.
    2. Convert the public image serverto a private image server.
      1. To create a private image based on an existing ECS, see section "Creating an Image" in the Elastic Cloud Server User Guide.
      2. Use the private image created in 2.a to create an ECS or change the ECS OS using the private image created in 2.a. For details, see section "Changing the OS" in the Elastic Cloud Server User Guide.
    3. Log in to the server and mount the file system again.