Help Center/ Cloud Data Migration/ FAQs/ Troubleshooting/ What Should I Do If the Cluster List Is Empty, I Have No Access Permission, or My Operation Is Denied?
Updated on 2022-09-15 GMT+08:00

What Should I Do If the Cluster List Is Empty, I Have No Access Permission, or My Operation Is Denied?

Symptom

When using CDM, you may encounter the following permission-related issues:

  • The cluster list is empty on the CDM homepage.
  • A message is displayed, indicating that you do not have the access permission.
  • When you try to start a job or restart a cluster, an error message is displayed, indicating that your operation is denied by the current policy.

Possible Cause

The preceding issues are caused by incorrect permission configuration.

Solution

  • If CDM is a module of DataArts Studio, perform the following operations:
    1. Check whether the DAYU Administrator or DAYU User role has been added. For details, see DataArts Studio Permissions Management.
    2. Check whether you have the permission (developer or viewer role) to access the workspace. For details, see DataArts Studio Permissions.
  • If CDM is an independent service, perform the following operations:
    1. Check whether IAM fine-grained authentication is enabled.
      • If it is disabled, check whether the CDM Administrator role has been added to the user group.
      • If it is enabled, go to 2.
    2. Check whether a custom or preset policy has been added to enable you to access CDM, such as the CDM FullAccess and CDM ReadOnlyAccess policies. For details, see Permissions Management.
    3. Check whether an access denial policy has been added to the enterprise project.