Help Center/ Data Lake Insight/ FAQs/ Flink Jobs/ O&M Guide/ Why Is Information Displayed on the FlinkUI/Spark UI Page Incomplete?
Updated on 2023-08-03 GMT+08:00

Why Is Information Displayed on the FlinkUI/Spark UI Page Incomplete?

Symptom

The Flink/Spark UI was displayed with incomplete information.

Possible Causes

The queue is a pay-per-use one. When the queue is used to run a job, the system releases the cluster and takes about 10 minutes to create a new one. Accessing the Flink UI before completion of the creation will empty the project ID in the cache. As a result, the UI cannot be displayed. The possible cause is that the cluster was not created.

Solution

Change the queue to dedicated, so that the cluster will not be released when the queue is idle. Alternatively, submit a job, wait for a while, and then access FlinkUI.