Why Is a Timeout Exception Reported When a DLI SQL Statement Fails to Be Executed on the Default Queue?
Symptom
[ERROR] Execute DLI SQL failed. Please contact DLI service. [ERROR] Error message:Execution Timeout
Possible Causes
The default queue is a public preset queue in the system for function trials. When multiple users submit jobs to this queue, traffic control might be triggered. As a result, the jobs fail to be submitted.
Solution
Buy a custom queue for your jobs. The procedure is as follows:
- In the navigation pane of the DLI management console, choose Queue Management.
- In the upper right corner of the Queue Management page, click Buy Queue to create a queue.
- On the Buy Queue page, set the required parameters as you need. Especially, set Type to For SQL.
- Submit your SQL jobs to the newly created queue.
O&M Guide FAQs
- How Do I View DLI Queue Load?
- How Do I Determine Whether There Are Too Many Jobs in the Current Queue?
- How Do I Switch an Earlier-Version Spark Queue to a General-Purpose Queue?
- Why Cannot I View the Resource Running Status of DLI Queues on Cloud Eye?
- How Do I Allocate Queue Resources for Running Spark Jobs If I Have Purchased 64 CUs?
- Why Is Error "Queue plans create failed. The plan xxx target cu is out of quota" Reported When I Schedule CU Changes?
- Why Is a Timeout Exception Reported When a DLI SQL Statement Fails to Be Executed on the Default Queue?
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