Why Is Error Message "Authentication failed" Displayed During Flink Jar Job Running?
Symptom
org.apache.flink.shaded.curator.org.apache.curator.ConnectionState - Authentication failed
Possible Causes
Service authorization is not configured for the account on the Global Configuration page. When the account is used to create a datasource connection to access external data, the access fails.
Solution
- Log in to the DLI management console. Choose Global Configuration > Service Authorization in the navigation pane.
- On the Service Authorization page, select all agency permissions.
Figure 1 Assigning agency permissions
- Click Update. If the message "Agency permissions updated successfully" is displayed, the modification is successful.
- After the authorization is complete, create a datasource connection and run the job again.
Flink Jar Jobs FAQs
- How Do I Configure Checkpoints for Flink Jar Jobs and Save the Checkpoints to OBS?
- Does a Flink JAR Job Support Configuration File Upload? How Do I Upload a Configuration File?
- Why Does the Submission Fail Due to Flink JAR File Conflict?
- Why Does a Flink Jar Job Fail to Access GaussDB(DWS) and a Message Is Displayed Indicating Too Many Client Connections?
- Why Is Error Message "Authentication failed" Displayed During Flink Jar Job Running?
- Why Is Error Invalid OBS Bucket Name Reported After a Flink Job Submission Failed?
- Why Does the Flink Submission Fail Due to Hadoop JAR File Conflict?
- How Do I Connect a Flink jar Job to SASL_SSL?
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.
more