Help Center/ Data Lake Insight/ FAQs/ Flink Jobs/ Flink Jar Jobs/ Why Is Error Message "Authentication failed" Displayed During Flink Jar Job Running?
Updated on 2023-05-19 GMT+08:00

Why Is Error Message "Authentication failed" Displayed During Flink Jar Job Running?

Symptom

An exception occurred when a Flink Jar job is running. The following error information is displayed in the job log:
org.apache.flink.shaded.curator.org.apache.curator.ConnectionState - Authentication failed

Possible Causes

Service authorization is not configured for the account on the Global Configuration page. When the account is used to create a datasource connection to access external data, the access fails.

Solution

  1. Log in to the DLI management console. Choose Global Configuration > Service Authorization in the navigation pane.
  2. On the Service Authorization page, select all agency permissions.

    Figure 1 Assigning agency permissions

  3. Click Update. If the message "Agency permissions updated successfully" is displayed, the modification is successful.
  4. After the authorization is complete, create a datasource connection and run the job again.