Why Is the Error Message "communication link failure" Displayed When I Use a Newly Activated Datasource Connection?
- Possible Causes
The network connectivity is abnormal. Check whether the security group is correctly selected and whether the VPC is correctly configured.
- Solution
Example: When you create an RDS datasource connection, the system displays the error message Communication link failure.
- Delete the original datasource connection and create a new one. When you create a new connection, ensure that the selected Security Group, VPC, Subnet, and Destination Address are the same as those in RDS.
Select a correct Service Type. In this example, select RDS.
Figure 1 Creating a basic datasource connection-RDS - Check the configurations of VPC.
If the error message is still displayed after you create a new datasource connection according to Step 1, check the VPC configuration.
- Classic datasource connections:
- Inbound rule: Check whether the inbound CIDR block and port in the security group have been enabled. If not, create the CIDR block and port you need.
Check whether the CIDR block and port are configured.Figure 2 Checking whether the CIDR block and port are configured
If no, add it.
Figure 3 Adding an inbound rule - Outbound rules: Check whether the CIDR block and port of the outbound rule are enabled. (It is recommended that all CIDR blocks be enabled.)
Check whether the CIDR block and port are configured.
Figure 4 Checking whether the CIDR block and port are configuredIf no, add it.
Figure 5 Adding an outbound rule
- Inbound rule: Check whether the inbound CIDR block and port in the security group have been enabled. If not, create the CIDR block and port you need.
- Enhanced datasource connections:
Check whether the CIDR block corresponding to the DLI queue is open. If no, add an outbound CIDR block in the VPC.
- Find the CIDR block corresponding to the queue bound to the datasource connection in DLI.
Figure 6 Searching for the CIDR clock corresponding to the queue bound to the datasource connection
- In the VPC security group, check whether the CIDR block corresponding to the DLI queue has been configured.
Figure 7 Checking the CIDR block corresponding to the DLI queue in the security group in the VPC
If no, add it.
Figure 8 Adding the corresponding CIDR to the VPC
- Find the CIDR block corresponding to the queue bound to the datasource connection in DLI.
- Classic datasource connections:
- Delete the original datasource connection and create a new one. When you create a new connection, ensure that the selected Security Group, VPC, Subnet, and Destination Address are the same as those in RDS.
Datasource Connection O&M FAQs
- Why Is the Error Message "communication link failure" Displayed When I Use a Newly Activated Datasource Connection?
- Connection Times Out During MRS HBase Datasource Connection, and No Error Is Recorded in Logs
- Why Can't I Find the Subnet When Creating a DLI Datasource Connection?
- Error Message "Incorrect string value" Is Displayed When insert overwrite Is Executed on a Datasource RDS Table
- Null Pointer Error Is Displayed When the System Creates a Datasource RDS Table
- Error Message "org.postgresql.util.PSQLException: ERROR: tuple concurrently updated" Is Displayed When the System Executes insert overwrite on a Datasource GaussDB(DWS) Table
- RegionTooBusyException Is Reported When Data Is Imported to a CloudTable HBase Table Through a Datasource Table
- A Null Value Is Written Into a Non-Null Field When a DLI Datasource Connection Is Used to Connect to a GaussDB(DWS) Table
- An Insert Operation Failed After the Schema of the GaussDB(DWS) Source Table Is Updated
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