Help Center/ Host Security Service/ FAQs/ Agent/ How Do I Fix an Abnormal Agent?
Updated on 2024-09-25 GMT+08:00

How Do I Fix an Abnormal Agent?

Your agent is probably abnormal if it is in Not installed or Offline state. Agent statuses and their meaning are as follows:

  • Uninstalled: No agent has been installed on the server, or the agent has been installed but not started.
  • Offline: The communication between the agent and the server is abnormal. The agent on the server has been deleted, or a non-Huawei Cloud server is offline.
  • Online: The agent on the server is running properly.

Possible Causes

  • The agent status on the console is not updated.

    The agent status has not been updated. After the agent is installed, it takes 5 to 10 minutes for the console to update its status.

  • OS version not supported.

    For details, see "Constraints" in "Service Overview".

  • The network is faulty.

    The agent or the cloud protection center is abnormal. For example, the NIC is faulty, the IP address changes, or the bandwidth is low.

  • The agent process is abnormal.

Solution

  1. Check whether the agent status remains Offline on the console for more than 10 minutes after the agent was installed.

    • If yes, go to 2.
    • If no, wait until the agent goes online. No further action is required. After the agent was installed, it takes 5 to 10 minutes for the console to update its status.

  2. Check whether your server OS is within the scope of support in "Constraints" in "Service Overview".

    • If yes, go to 3.
    • If no, the HSS agent cannot be installed or run on your server. Upgrade the OS to a version supported by HSS and try again.

  3. Check whether the server network is normal.

    • If yes, go to 4.
    • If no, ensure the security group of your server allows access to port 10180 of the 100.125.0.0/16 CIDR block in the outbound direction and the server can access the network. After the server can access the network, check the agent status.

  4. Check whether the available memory of the server is greater than 300 MB.

    • If yes, go to 5.
    • If no, the agent will go offline due to insufficient server memory. After the capacity expansion is complete, the agent will go online again.

  5. Restart the agent process.

    • Windows
      1. Log in to the server as user administrator.
      2. Open the Task Manager.
      3. On the Services tab page, select HostGuard.
      4. Right-click the service and choose Restart.
    • Linux

      Run the following command in the CLI as user root to restart the agent:

      /etc/init.d/hostguard restart

      If the following information is displayed, the restart is successful:
      root@HSS-Ubuntu32:~#service hostguard restart/etc/init.d/hostguard  restart
      Stopping Hostguard...
      Hostguard stopped
      Hostguard restarting...
      Hostguard is running

    After the process is restarted, wait for about 2 minutes.

    • If the agent status is Online, no further action is required.
    • If the agent status is still Not installed or Offline, uninstall the agent and install it again.