Why Is a BMS with the Agent Installed Displayed in the ECS List on the Server Monitoring Page?
Symptoms
The Agent was installed on a BMS, but the BMS is listed on the Server Monitoring > Elastic Cloud Server page on the Cloud Eye console.
Possible Causes
The Agent determines whether a server is an ECS or BMS based on the services provided by IP address 169.254.169.254. If the route for this address is changed, the Agent will consider the server to be an ECS by default.
Solution
Manually modify the Agent configuration file by adding BMS identifier BmsFlag and setting it to true.
- Linux OS: See (Optional) Manually Configuring the Agent for Linux.
- Windows OS: See (Optional) Manually Configuring the Agent for Windows.
Server Monitoring FAQs
- How Does the Cloud Eye Agent Obtain a Temporary AK/SK by Authorization?
- How Can I Quickly Restore the Agent Configuration?
- How Can I Ensure that a Newly Purchased ECS Comes with the OS Monitoring Function?
- Why Is a BMS with the Agent Installed Displayed in the ECS List on the Server Monitoring Page?
- What OSs Does the Agent Support?
- What Statuses Does the Agent Have?
- What Should I Do If the Monitoring Period Is Interrupted or the Agent Status Keeps Changes?
- What Should I Do If the Service Port Is Used by the Agent?
- What Should I Do If the Agent Status Is Faulty?
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