Help Center> Cloud Eye> User Guide> Troubleshooting> One-Click Agent Restoration Fails

One-Click Agent Restoration Fails

Symptom

After you click Restore Agent Configurations, the Agent status is still Configuration error.

Possible Cause

Check the following items to troubleshoot the fault:

  1. DNS configuration
  2. IAM agency configuration
  3. User permissions

Solution

  1. Check the DNS configuration.

    1. Log in to the management console.
    2. Under Computing, select Elastic Cloud Server.
    3. Click the name of the ECS.

      The ECS details page is displayed.

    4. Click the VPC name.

      The VPC console is displayed.

    5. In the VPC list, click the VPC name.
    6. On the Subnets tab, check whether the DNS server addresses are correct.

      For details about how to configure the DNS servers in different regions, see Modifying the DNS Server Address and Adding Security Group Rules (Windows) or Modifying the DNS Server Address and Adding Security Group Rules (Linux).

      Figure 1 DNS server address

  2. Check the IAM agency configuration.

    1. Log in to the management console.
    2. Hover your mouse on the username and click Identity and Access Management.
    3. On the IAM console, choose Agencies.
    4. Check whether there is an agency named CESAgentAutoConfigAgency.

      If not, create the agency. You can delete unnecessary agencies if the agency quota has been reached.

  3. Check user permissions.

    1. Log in to the management console.
    2. Hover your mouse on the username and click Identity and Access Management.
    3. In the navigation pane on the left, click User Groups.
    4. Locate your user group and click Assign Permissions in the Operation column.
    5. To install the Agent, you must have the following permissions:
      • Global: Security Administrator
      • Region: ECS CommonOperationsr or BMS CommonOperations, and CES Administrator or CES FullAccess
        Figure 2 User permissions required for installing the Agent