更新时间:2024-05-17 GMT+08:00
绑定密钥对失败如何处理?
问题描述
当对弹性云服务器执行绑定密钥对操作时失败。
- 管理控制台上“密钥对执行失败记录”对话框中的失败记录只记录了弹性云服务器的操作历史,不会影响弹性云服务器的状态及后续操作,可单击失败记录所在行的“删除”,直接删除失败记录,或者单击“删除所有失败记录”,删除所有执行失败的记录。
- 单击“了解更多”,查看相关文档。
可能原因
- 用户提供了错误或者失效的密码。
- 用户修改了公钥文件权限或属组。
- 用户修改了弹性云服务器的SSH配置。
- 弹性云服务器安全组22端口入方向未对100.125.0.0/16开放。
- 在弹性云服务器执行密钥对绑定期间,用户对弹性云服务器进行关机、开启或者卸载磁盘等操作。
- 网络发生故障。
- 弹性云服务器设置了防火墙规则。
处理方法
- 查看弹性云服务器的状态。
- 使用密码登录弹性云服务器,检查密码是否正确。
- 正确,请执行步骤 4。
- 错误,请使用正确的密码再次执行绑定密钥对操作。
- 检查弹性云服务器的“/root/.ssh/authorized_keys”文件权限路径和属组是否被修改过。
- 是,请恢复至以下权限:
- 每级属组都是root:root权限。
- .ssh权限为700。
- authorized_keys权限为600。
- 否,请执行步骤 4。
- 是,请恢复至以下权限:
- 检查弹性云服务器的“/root/.ssh/authorized_keys”文件是否被修改过。
- 是,请根据实际情况恢复“/root/.ssh/authorized_keys”文件的原始内容。
- 否,请执行步骤 5。
- 检查ECS安全组22端口入方向是否对100.125.0.0/16开放,即允许100.125.0.0/16地址通过SSH远程连接到Linux弹性云服务器。
- 请检查执行密钥对绑定操作的弹性云服务器是否可以正常开机、关机和登录使用等操作。
- 是,请再次执行绑定密钥对操作。
- 否,请执行步骤 7。
- 检查网络是否发生故障。
- 是,请联系技术支持工程师查看并定位原因。
- 否,请再次执行绑定密钥对操作。
父主题: 密钥对管理类