文档首页> 数据治理中心 DataArts Studio> 常见问题> 数据开发> 查看日志时,系统提示“OBS日志文件不存在,请检查文件是否被删除或者没有OBS写入权限。”怎么办?
更新时间:2023-10-12 GMT+08:00
分享

查看日志时,系统提示“OBS日志文件不存在,请检查文件是否被删除或者没有OBS写入权限。”怎么办?

问题现象

查看数据开发的节点日志时,系统提示“OBS日志文件不存在,请检查文件是否被删除或者没有OBS写入权限”,如下图所示:

图1 提示信息

原因分析

数据开发的日志存储在OBS桶中,您所在的用户组没有OBS的操作权限,导致在查看节点日志时系统提示报错,或者OBS日志文件不存在时系统提示报错。

解决方法

  1. 管理员登录IAM控制台。
  2. 在统一身份认证服务的左侧导航窗格中,选择“用户”,单击用户名进入用户信息界面。
  3. 查看用户所属的用户组。
    图2 用户所属的用户组

  4. 在左侧导航窗格中,选择“用户组”,单击用户所属的用户组后面“操作”列的“授权”
  5. 在授权界面,选择需要给用户组添加的权限,搜索需要的权限名称,请配置为OBS OperateAccess或OBS Administrator。
    图3 给用户组授权

  6. 单击“下一步”,选择最小授权范围,系统默认“所有资源”。
  7. 单击“确定”。

    如果权限没有问题,请检查OBS日志文件是否存在。

运行作业后查看日志时系统提示“OBS日志文件不存在,请检查文件是否被删除或者没有OBS写入权限”的处理方法

  1. 管理员登录IAM控制台。
  2. 在统一身份认证服务的左侧导航窗格中,选择“用户”,单击用户名进入用户信息界面。
  3. 单击“访问方式”后面的,修改访问方式。
  4. 勾选“编程访问”和“管理控制台访问”。
    图4 配置访问方式

  5. 单击“确定”。
    • 在管理控制台创建工作空间时,作业日志OBS路径只支持OBS对象桶,不支持并行文件系统。如果不配置作业日志OBS路径,DataArts Studio数据开发默认会把日志写到dlf-log-{projectId}桶中,DataArts Studio数据服务默认会把日志写到dlm-log-{projectId}桶中。
    • 如果“作业日志OBS路径”没有选择已有的OBS桶,首次运行作业时,默认的DLF桶创建不出来,无法写入日志。为了确保作业日志正常写入OBS桶中,当创建工作空间时,请选择已有的OBS路径。
分享:

数据开发 所有常见问题

more