在账号管理中查看密码,提示没有权限如何处理?
问题描述
在账号管理中执行密码查看操作时,页面提示用户无查看密码权限,如下图所示。
原因分析
查看密码通常涉及到两个主要步骤:获取加密的密码和解密密码。这两个步骤分别需要coc:account:getPassword和kms:dek:decrypt权限。因此,在查看密码前,请确保用户当前登录账号已获取对应授权。
解决方案
- 登录IAM控制台。
若无IAM访问权限,请联系管理员处理。
图1 无IAM访问权限 - 在左侧导航栏选择“用户”,进入用户列表页面。
图2 查看用户列表
- 在用户列表中单击待查看的用户名称,进入用户详情页面。
- 选择授权记录页签,查看当前用户所有授权。
图3 查看用户授权记录
- 单击权限名称查看详情,在策略内容中确认Action列表中是否包含coc:account:getPassword和kms:dek:decrypt权限。
图4 确认权限
- 如果当前账号缺少所需权限,请联系账号管理员,在IAM中为登录用户申请coc:account:getPassword和kms:dek:decrypt权限。
具体操作可参见创建用户组并授权。