文档首页/ 云容器引擎 CCE/ 常见问题/ 网络管理/ 网络异常问题排查/ 集群内部无法使用Service的ELB地址访问负载
更新时间:2026-09-23 GMT+08:00
分享

集群内部无法使用Service的ELB地址访问负载

问题现象

在集群内部(节点上或容器中),无法使用Service的ELB地址访问负载。

问题场景一:Service设置了服务亲和为节点级别

问题场景二:IPVS转发模式的集群中ELB实例复用

问题原因

IPVS转发模式的集群中,存在以下两种场景可能导致ELB地址访问不通:

  • ELB Ingress和Service关联使用相同的ELB实例,集群内访问Ingress时会被ipvs-0网桥劫持到Service地址,导致无法访问。
  • 本集群的Service和其他集群的Service关联使用相同的ELB实例,集群内访问其他集群的Service时会被ipvs-0网桥劫持到本集群内的Service地址,导致无法访问。

解决方案

建议您避免以上使用场景。若业务必须共用ELB,请为所有关联该ELB的Service启用pass-through能力,以绕过kube-proxy的IPVS转发。详情请参见为负载均衡类型的Service配置pass-through能力。

问题场景三:IPVS转发模式的集群中负载均衡类Service使用区间端口

问题原因

Service的“区间端口监听”支持通过ELB实现范围端口的监听能力(例如端口范围为30000-30005),但集群内访问仅支持spec.ports中配置的port端口(30000),其余端口(30001-30005)会因为ipvs-0网桥劫持访问失败。

解决方案

如果需要在集群内访问Service区间端口,请为配置区间端口的负载均衡类Service启用pass-through能力,以绕过kube-proxy的IPVS转发。详情请参见为负载均衡类型的Service配置pass-through能力。

相关文档