
# 通过DAS连接RDS for MySQL实例（推荐）
#### 操作场景
数据管理服务（Data Admin Service，简称DAS）是一款专业的简化数据库管理工具，提供优质的可视化操作界面，大幅提高工作效率，让数据管理变得既安全又简单。您可以通过数据管理服务连接并管理实例。云数据库RDS服务默认为您开通了远程主机登录权限，推荐您使用更安全便捷的数据管理服务连接实例。
#### 操作步骤
1. [登录管理控制台](https://console.huaweicloud.com/rds/#/rds/management/list)。
2. 单击管理控制台左上角的![](https://support.huaweicloud.com/usermanual-rds-mysql/zh-cn_image_0000002593881161.png)，选择区域。
3. 在"实例管理"页面，选择目标实例，单击操作列的"登录"，进入数据管理服务实例登录界面。 
   图1登录实例   
   ![](https://support.huaweicloud.com/usermanual-rds-mysql/zh-cn_image_0000002212063804.png "点击放大")
   您也可以在"实例管理"页面，单击目标实例名称，在页面右上角，单击"登录"，进入数据管理服务实例登录界面。
   图2登录实例   
   ![](https://support.huaweicloud.com/usermanual-rds-mysql/zh-cn_image_0000002247143601.png "点击放大")
   
   
4. 正确输入数据库用户名和密码，单击"登录"，即可进入您的数据库并进行管理。 
   - 登录用户名：root
   
   - 密码：填写创建实例时设置的root密码。如果忘记密码，可以重置密码，详见[重置管理员密码和root账号权限](https://support.huaweicloud.com/usermanual-rds-mysql/rds_reset_password.html)。
   
   
   图3登录界面   
   ![](https://support.huaweicloud.com/usermanual-rds-mysql/zh-cn_image_0000002212223592.png "点击放大")
   
   
 
#### 常见问题
#### 在实例列表的操作列单击"登录"时，无法跳转至DAS页面怎么办？
请将您的浏览器设置为允许弹出窗口，然后重试。
#### 权限不足导致实例连接失败怎么办？
1. 报错信息：您的权限不足。策略不允许执行 das:connections:xxx。 报错原因：您的账号没有添加DAS FullAccess权限。
   解决方法：请参考[创建用户并授权使用DAS](https://support.huaweicloud.com/usermanual-das/das_08_0003.html)，添加DAS FullAccess权限。
   
2. 报错信息：您没有执行此操作的权限，请联系您的管理员为您开通权限。 报错原因：您的账号没有添加DAS FullAccess权限。
   解决方法：请参考[创建用户并授权使用DAS](https://support.huaweicloud.com/usermanual-das/das_08_0003.html)，添加DAS FullAccess权限。
   
3. 报错信息：您当前登录的账号仅具有只读权限，不能执行此操作。为确保您顺利使用DAS，请添加DAS Administrator权限。 报错原因：您的账号没有添加DAS FullAccess权限。
   解决方法：请参考[创建用户并授权使用DAS](https://support.huaweicloud.com/usermanual-das/das_08_0003.html)，添加DAS FullAccess权限。
   
 
#### 通过DAS连接实例失败怎么办？
1. 报错信息：Access denied for user 'user_name'@'100.xxx.xx.xx' (using password: YES)。
   1. 报错原因：RDS实例用户名或密码不对。
      解决方法：请确认数据库用户名和密码是否正确，如果忘记密码，可以在RDS控制台重置实例密码。
      ![](https://support.huaweicloud.com/usermanual-rds-mysql/public_sys-resources/notice_3.0-zh-cn.png)
      修改密码可能会影响业务，请谨慎操作。
      如果确认账户名和密码正确，可以通过客户端或命令行工具登录数据库，执行select \* from mysql.user where user = 'user_name'命令查看用户信息，如果存在100.%网段的用户，则DAS只能通过100.%网段的数据库用户去连接数据库。user_name @%与user_name @100.%是两个用户，其密码和权限都是独立的，请确认输入的密码是否是user_name @100.%用户的密码。
      
   
   2. 报错原因：DAS服务器的IP地址不在您输入用户的白名单中。
      解决方法：使用客户端或命令行工具登录到数据库，创建DAS可以访问的数据库用户。
      ```
      create user 'user_name'@'100.%' identified by 'password'; 
      grant select on *.* to 'user_name'@'100.%';
      ```
      ![](https://support.huaweicloud.com/usermanual-rds-mysql/public_sys-resources/note_3.0-zh-cn.png)
      - DAS服务器IP地址所在网段为100.%，请根据实际使用需要添加白名单。
      
      - 请根据实际使用需要给user_name@100.%用户赋予权限。
        
   
   3. 报错原因： 使用SSL用户登录，服务端没有开启SSL功能。 解决方法：请执行如下语句查询用户是否是SSL用户，如果是，则在RDS实例详情页面，将SSL开关打开。其中，ssl_type字段有值即表示此用户是SSL用户。
      ```
      select user, host, ssl_type from mysql.user where user = 'user_name';
      ```
      
    
2. 报错信息： Trying to connect with ssl, but ssl not enabled in the server. 报错原因： 使用SSL用户登录，服务端没有开启SSL功能。
   解决方法：请执行如下语句查询用户是否是SSL用户，如果是，则在RDS实例详情页面，将SSL开关打开。其中，ssl_type字段有值即表示此用户是SSL用户。
   ```
   select user, host, ssl_type from mysql.user where user = 'user_name';
   ```
   
3. 报错信息： Client does not support authentication protocol requested by server. plugin type was = 'sha256_password'.
   1. 报错原因： DAS暂不支持密码的加密方式为sha256_password的数据库用户连接登录。
      解决方法：请执行如下语句将密码的加密方式改为mysql_native_password。
      ```
      alter user 'user_name'@'%' identified with mysql_native_password by 'password';
      ```
      
   
   2. 报错原因：对于MySQL 8.0，DAS服务器的IP地址不在您输入用户的白名单中。 解决方法：使用客户端或命令行工具登录到数据库，创建DAS可以访问的数据库用户。
      
    
4. 报错信息： Communications link failure The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server. 报错原因： DAS服务器与实例网络不通。
   解决方法：请[提交工单](https://console.huaweicloud.com/ticket/?locale=zh-cn#/ticketindex/business?productTypeId=2a129f7ed0b543c6b92d73e2c26aa590&subTypeId=-1&type=2)联系客服人员协助处理。
   
5. 报错信息：Instance connect timeout, please login again. 报错原因：DAS服务器连接超时。
   解决方法：请[提交工单](https://console.huaweicloud.com/ticket/?locale=zh-cn#/ticketindex/business?productTypeId=2a129f7ed0b543c6b92d73e2c26aa590&subTypeId=-1&type=2)联系客服人员协助处理。
   
6. 报错信息：RSA public key is not available client side (option serverRsaPublicKeyFile not set).
   报错原因：数据库用户的身份认证方式对密码安全性要求较高，要求用户认证过程中在网络传输的密码是加密的。
   - 如果是SSL加密连接，则使用SSL证书和密钥对来完成"对称加密密钥对（在TLS握手中生成）"的交换，后续使用"对称加密密钥对"加密密码和数据。
   
   - 如果是非SSL加密连接，则在连接建立时客户端使用MySQL Server端的RSA公钥加密用户密码，Server端使用RSA私钥解密验证密码的正确性，可以防止密码在网络传输时被窥探。
    
   解决方法：开启实例SSL或者修改数据库用户的身份认证方式。
   
 
#### 后续操作
登录实例后，您可以创建数据库，进行数据迁移等操作，具体请参见：
- [通过界面可视化创建MySQL数据库](https://support.huaweicloud.com/usermanual-rds-mysql/rds_05_0019.html)
- [通过调用API创建MySQL数据库](https://support.huaweicloud.com/api-rds/rds_06_0007.html)
- [迁移方案总览](https://support.huaweicloud.com/usermanual-rds-mysql/rds_05_0001_03.html)
 
