
# ALM-50222 BE中指定数据目录的磁盘状态异常
#### 告警解释
系统每30秒周期性检查BE中指定数据目录的磁盘状态，当检查到该值不等于1（1表示正常，0表示异常）时产生该告警。BE中指定数据目录的磁盘状态恢复正常，告警清除。
#### 告警属性
| 告警ID  | 告警级别 | 是否可自动清除 |
|:---|:---|:---|
| 50222 | 紧急   | 是       |
   
#### 告警参数
| 参数名称              | 参数含义                  |
|:---|:---|
| 来源                | 产生告警的集群或系统名称。         |
| 服务名               | 产生告警的服务名称。            |
| 角色名               | 产生告警的角色名称。            |
| 主机名               | 产生告警的主机名。             |
| Trigger Condition | 系统当前指标取值满足自定义的告警设置条件。 |
   
#### 对系统的影响
可能会导致业务数据不可用，在Doris客户端查询数据失败。
#### 可能原因
- 硬盘故障。
- 磁盘权限设置不正确。
 
#### 处理步骤
**查看是否存在磁盘告警**
1. 在FusionInsight Manager首页，选择"运维 \> 告警 \> 告警"，查看是否存在告警"ALM-12014 设备分区丢失"或"ALM-12033 慢盘故障"。 
   - 是，执行[步骤 2]。
   
   - 否，执行[步骤 4]。
   
   
   
   
2. 参考[ALM-12014 设备分区丢失](https://support.huaweicloud.com/usermanual-mrs/ALM-12014.html)或[ALM-12033 慢盘故障](https://support.huaweicloud.com/usermanual-mrs/ALM-12033.html)告警进行处理，查看对应告警是否清除。
   
   - 是，执行[步骤 3]。
   
   - 否，执行[步骤 4]。
   
   
   
   
3. 等待五分钟，检查该告警是否恢复。
   
   - 是，处理完毕。
   
   - 否，执行[步骤 4]。
   
   
   
   
**修改磁盘权限**
4. 在"运维 \> 告警 \> 告警"页面，查看该告警的"定位信息"和"附加信息"，获取该告警上报的故障磁盘位置信息。
5. 以**root** 用户登录上报告警的节点，用户密码为安装前用户自定义，请咨询系统管理员，进入故障磁盘所在目录，使用**ll** 命令查看该故障磁盘的权限是否711，用户是否为**omm** 。
   
   - 是，执行[步骤 7]
   
   - 否，执行[步骤 6]。
   
   
   
   
6. 修改故障磁盘权限，如故障磁盘为data1，则执行以下命令：
   
   **chown omm:wheel data1**
   **chmod 711 data1**
   
   
7. 选择"集群 \> 服务 \> Doris \> 实例"，勾选该BE实例，选择"更多 \> 重启实例"，等待五分钟，查看是否有新的告警上报。
   
   - 否，处理完毕。
   
   - 是，执行[步骤 8]。
   
   
   ![](https://support.huaweicloud.com/usermanual-mrs/public_sys-resources/notice_3.0-zh-cn.png)
   在BE实例重启期间，运行在对应BE节点上的任务会失败，未进行重启的BE节点上的任务不受影响。
   
   
**收集故障信息**
8. 在FusionInsight Manager首页，选择"运维 \> 日志 \> 下载"。
9. 在"服务"中勾选待操作集群的"Doris"和"OMS"。
10. 单击右上角的时间编辑按钮，设置日志收集的"开始时间"和"结束时间"分别为告警产生时间的前后20分钟，单击"下载"。
11. 请联系运维人员，并发送已收集的故障日志信息。
 
#### 告警清除
此告警修复后，系统会自动清除此告警，无需手工清除。
#### 参考信息
不涉及。
