
# ALM-50217 FE节点堆内存的使用率超过阈值
#### 告警解释
系统每30秒周期性检查FE节点堆内存的使用率，当检查到该值超出阈值（默认值为95%）时产生该告警。
当FE节点堆内存的使用率低于阈值时，告警清除。
#### 告警属性
| 告警ID  | 告警级别 | 是否可自动清除 |
|:---|:---|:---|
| 50217 | 紧急   | 是       |
   
#### 告警参数
| 参数名称              | 参数含义                  |
|:---|:---|
| 来源                | 产生告警的集群或系统名称。         |
| 服务名               | 产生告警的服务名称。            |
| 角色名               | 产生告警的角色名称。            |
| 主机名               | 产生告警的主机名。             |
| Trigger Condition | 系统当前指标取值满足自定义的告警设置条件。 |
   
#### 对系统的影响
影响任务执行和客户端连接FE。
#### 可能原因
FE堆内存过小。
#### 处理步骤
**检查堆内存使用率。**
1. 登录FusionInsight Manager，选择"运维 \> 告警 \> 阈值设置 \> *待操作集群的名称* \> Doris \> CPU和内存 \> FE节点堆内存的使用率 (FE)"。
   
   1. 单击"平滑次数"后的编辑按钮，根据实际使用情况，修改平滑次数配置项，单击"确定"。
   
   2. 单击"操作"列的"修改"，根据实际使用情况，更改告警阈值，单击"确定"。
   
   
   
   
2. 在FusionInsight Manager首页，选择"集群 \> 服务\> Doris \> FE \> 配置 \> 全部配置"，搜索"FE_GC_OPTS"参数，将"-Xmx"的值根据实际情况调大，并单击"保存"，单击"确定"。 
   ![](https://support.huaweicloud.com/usermanual-mrs/public_sys-resources/note_3.0-zh-cn.png)
   - 出现此告警时，说明当前Doris实例设置的堆内存无法满足当前数据传输所需的堆内存，建议打开实例监控界面，在页面上查看"Doris堆内存资源状况"监控图表，观察该监控图表中"Doris使用的堆内存大小"的变化趋势，根据当前堆内存使用的大小，调整"-Xmx"的值为当前堆内存使用量的两倍（或根据实际情况进行调整）。
   
   - 注意堆内存设置时，可以设置"-Xms"和 "-Xmx"近似相等，从而避免每次GC后调整堆的大小，引起性能下降。
   
   - "-Xmx"与"XX:MaxPermSize"之和不能大于该节点服务器的实际物理内存值。
    
   
   
3. 重启受影响的服务或实例，观察界面告警是否清除。 
   - 是，处理完毕。
   
   - 否，执行[步骤 4]。
   
   
   ![](https://support.huaweicloud.com/usermanual-mrs/public_sys-resources/notice_3.0-zh-cn.png)
   - 在Doris服务重启期间服务不可用，不能对外提供服务，且其他连接Doris运行的任务也会失败。
   
   - 在实例重启期间，运行在对应实例节点上的任务会失败，未进行重启的实例节点上的任务不受影响。
    
   
   
**收集故障信息。**
4. 在FusionInsight Manager界面，选择"运维 \> 日志 \> 下载"。
5. 在"服务"框中勾选待操作集群的"Doris"。
6. 单击右上角的时间编辑按钮，设置日志收集的"开始时间"和"结束时间"分别为告警产生时间的前后10分钟，单击"下载"。
7. 请联系运维人员，并发送已收集的故障日志信息。
 
#### 告警清除
此告警修复后，系统会自动清除此告警，无需手工清除。
#### 参考信息
不涉及。
